Philipp Stephani writes:
> >> - \exp_arg_unbraced:No === \exp_after:wN
> > You'd like this to exist, you mean?
> Yes, I just think it fits better with the other _unbraced macros (it would
> be the simplest of those).
> Please note that the three points you commented on are just related to
> design or style decisions, there is nothing wrong with how it is currently
> implemented in expl3.
for a start \exp_after:wN should normally not be needed except on very
low-level programming (which should largely only happen in the kernel). For
the rest the l3expan concept really provides a much more powerful and
I know that for 2e programmers that is a bit of a getting used to as we all
used \expandafter in the past all over the place, but in reality it isn't
So providing yet another name for it isn't something I like to see without
compelling reasons and I'm not sure there is one (but perhaps 'm mistaken).
If we would add it then I guess the right name wouldn't be
\exp_arg_unbraced:No - it would fit more into the group of functions called
\exp_last_unbraced:N... but as I said I'm not really sure that adding that
would help, would it?