text/plain; format=flowed; delsp=yes; charset=iso-8859-1
Wed, 5 Dec 2007 09:30:52 +0100
On Sun, 02 Dec 2007 14:35:33 +0100, Andreas Matthias wrote:
> Recently, the names of some control sequences were changed in svn.
> Maybe this is a good time to think about other names as well.
> * \int_set:Nn uses \numexpr to scan its second argument. Shouldn't
> it rather be called \int_set:Nx?
True, the base form of the function \int_set: does do this x expansion.
However, these assignment functions are a bit different from other types
because there is no difference between \int_set:Nn and \int_set:Nx and so
perhaps it is better to stick to the base form definition using Nn rather
than Nx as that would imply there is a base form too.
For things such as \int_compare:nNnTF, having a name with xNxTF argument
spec might imply the function is not expandable but it is.
> * \quark_if_no_value gives the impression that this is a test
> `if a quark has no value'. But actually it is a test `if a token
> list is equal to \q_no_value'. Wouldn't \tlist_if_q_no_value be
> a better name?
> Same for: \quark_if_nil --> \tlist_if_q_nil
The quark functions need a bit of clarification. Just the other day I
uploaded a new version where there is one special quark used for tail
recursions and functions testing for just this quark.
What is more or less implemented now for \q_nil etc. is that the test is
essentially a \tlist test so your question makes a lot of sense. However,
the original concept was not this but rather that one should just check if
a token list begins with such a quark because it should happen under
controlled circumstances. The new tail recursion tests is a step in that
direction so that there is a well-defined interface for using the quark.
So far l3tlp and l3clist have been updated to use it, others will follow.