Manuel Pégourié-Gonnard a écrit :
> No one (at least not me) wants to impede progress. luainputenc and
> are interesting and I'm glad they are being developed. The question is: Would it
> be a real progress to have them called 'inputenc' (by whatever mechanism such
> as kpse search path or something like Élie's suggestion)?
> In the current state of the packages, I don't think it would be a progress to
> change the name to inputenc. And I also think there's no need to hurry deciding
> whether it is a progress or not.
In the future LuaTeX will probably replace pdfTeX, so inputenc will load
luainputenc. The question is not really to decide if it's good or not,
it's to decide when we will do it. And I still can't really see why we
should wait three more years...
> If the user is aware enough of what's going on, she is probably able to
> understand that she should use luainputenc instead of inputenc (or, much better,
> (re-)encode her source as utf-8 and stop using *inputenc).
Just to repeat myself: (lua)inputenc is not optional in most cases, so
the user will have to load luainputenc. This means that people working
with LuaLaTeX will have to change their documents in 2012, replacing
luainputenc by inputenc... I know it's not 100% stable so users must
know what they're doing, but it still seems more annoying than the
miracle solution for stability...