LISTSERV mailing list manager LISTSERV 16.0

Help for LATEX-L Archives


LATEX-L Archives

LATEX-L Archives


LATEX-L@LISTSERV.UNI-HEIDELBERG.DE


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Monospaced Font

LISTSERV Archives

LISTSERV Archives

LATEX-L Home

LATEX-L Home

LATEX-L  March 2011

LATEX-L March 2011

Subject:

Re: expl3's seq_pop_right etc.

From:

Frank Mittelbach <[log in to unmask]>

Reply-To:

Mailing list for the LaTeX3 project <[log in to unmask]>

Date:

Fri, 18 Mar 2011 21:06:20 +0100

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (169 lines)

Bruno,

 > To be clear, I'm perfectly ready to keep the old interface. I was
 > mostly concentrating on the implementation, and some functions
 > appeared more natural than the existing ones in that context.

I'm not saying that the old interfaces need to stay or should stay, only that
it is helpful if they do at least initially. And the discussion so far shows
(and showed in the past) that there are improvements possible.

By the way, with the interfaces but back in the compatibility section shows
some failures in some files that need checking. Not really got around checking
for cause.

xor certainly dies because some of its code misuses the seq implementation and
hacks into \seq_elt:w so not surprising this dies. For others I don't know
yet.

 > > > Then there is the issue of l3candidates, which I have not
 > > > re-programmed yet, as well as the quicksort defined in l3prg.dtx
 > >
 > > one step at a time i'd say.
 >
 > I meant that there are some \seq_from_clist and \clist_from_seq
 > functions in l3candidates which will have to be rewritten, and a
 > \seq_quicksort, or something like that, which I haven't looked at. I'm
 > _definitely not_ rewriting l3prg.dtx :).

you are not? :-) pity. But this is what I meant: none of these are on the
critical path. So I was just agreeing with you that there is no need to
rewrite them just to experiment with a new seq implementation. Of course if we
decide to adopt it, then we need to do those rewrites, eventually.


 > > > - I don't like the fact that \seq_(g)pop return its value locally, so
 > > > I changed which functions are provided there to \seq_pop_with:Nn <seq>
 > > > {<assignment code>}.
 > >
 > > Im not sure here.
 > >
 > > - the general design principle is that all functions that get values from
 > > some data structure *always* store them *locally* in a variable.
 > >
 > > - the data structure itself could be local or global and a manipulation of
 > > the structure could then be local or global too.
 >
 > Is there any example of data structure other than seq or prop?

not much at the moment in terms of kernel data structures, only clists I
think. But for the outputroutine and the like I guess you will have other
complex data structures from which you need to pick up values.

 >
 >
 > > On the other hand popping + using the value is a quite common usage, so to
 > > have to always write
 > >
 > > \seq_pop_left_with:Nn \l_foo_seq {\tl_set:Nn \l_bar_tl}
 > >
 > > instead of
 > >
 > > \seq_pop:NN \l_foo_seq \l_bar_tl
 >
 > I see your point. Then perhaps renaming \seq_pop_left_with:Nn to
 > \seq_pop_left_do:Nn, and leaving \seq_pop:NN as it is could make
 > sense. Then if we just want to remove the left-most element and apply
 > some function onto it, we can do
 >
 > \seq_pop_left_do:Nn \l_foo_seq {\foo:nn {<arg1>}}
 >
 > and to get a global return value we would do
 >
 > \seq_pop_left_do:Nn \l_foo_seq {\tl_gset:Nn \g_foo_tl}
 >
 > Basically, I'm just making an auxiliary function available to the user.

I must say I rather like \seq_pop_left_with:Nn as a generic approach. It is
just that I don't want to drop the function that one normally needs for it.
And I rather prefer the _pop_with to _pop_do.

As to the naming, of course one could go for

 \seq_get_pop:NN

or even

 \seq_get_pop_left:NN

and then one could have all variations without any ambiguity to what is local
and global, eg

 \seq_gget_pop:NN
 \seq_get_gpop:NN
 \seq_gget_gpop:NN

perhaps that's better but I'm not sure if it is not just making things longer

 >
 > > now having written that I noticed that it isn't true, this is violated in
 > > l3prop where there are gget functions for key values, so hmmm ... still I
 > > tend towards the rule above I guess
 >
 > I think that you are right: there should be a \..._pop_left:NN, which
 > does something consistent between the various data structures.
 > Choosing local return values is as good as anything.

Well I'm not too sure myself here, the discussion is certainly helpful


 > > > - I'd like every "..._map_function:NN" to become
 > > > "..._map_function:Nn", i.e. allow mapping several tokens at a time. It
 > >
 > > Personally I don't find this very intuitive; if you map a function you
 > > map a function name and that would mean N. Besides you would lose the
 > > ability to map a constructed function name ie "c" though that is
 > > something you would seldom need I guess.
 >
 > My initial application was to be able to map a function with two
 > arguments on two seq <a> and <b> at the same time. First I zipped the
 > two seq into one seq whose item each have the form {<a_i>}{<b_i>}.
 > Then I could map _expandably_
 >
 > \seq_map_function:Nn \l_foo_zipped_seq {\exp_after:wN \foo_func:nn \use:n}
 >
 > where the \use:n unbraces its argument. Not a very convincing use.

No not really :-) if it is a serious use I would probably encapsulate it by
its own functions and then use those, but anyway ...

 > But Lars Madsen's examples with { \foo_func:nn {arg1} } are better.

yes probably

 > > I would rather do
 > >
 > > \cs_new:Npn \map_func:n #1 {<some tokens> \func:n #1}
 > > ...map_function:NN \l_foo_seq \map_func:n
 >
 > That would be better as
 >
 > ...map_inline:Nn \l_foo_seq {<some tokens> \func:n {#1}}
 >
 > The key here is expandability. When it is not needed, map_inline:Nn
 > and map_variable:NNn fit the bill nicely. The best might be to leave
 > both the :NN and :Nn variants, synonyms of each other, hence taking
 > little of TeX's memory.

probably.

 > There is also the question of whether removing an elements once/all
 > copies of it should be named as in l3clist or l3tl:
 >
 > \clist_remove_element:Nn
 > \tl_remove_all_in:Nn
 > \tl_remove_in:Nn
 >
 > I'd go for the tl version.

agreed some concistency in the naming would be in order. About the actual
names to use I'm not so sure. Must confess I wasn't aware of the tl ones at
all. The _in seems to me unnecessary and I would personally prefer

 \tl_remove_once:Nn
 \tl_remove_all:Nn

etc.

cheers
frank

Top of Message | Previous Page | Permalink

Advanced Options


Options

Log In

Log In

Get Password

Get Password


Search Archives

Search Archives


Subscribe or Unsubscribe

Subscribe or Unsubscribe


Archives

September 2019
July 2019
April 2019
March 2019
February 2019
January 2019
December 2018
November 2018
October 2018
September 2018
August 2018
June 2018
May 2018
April 2018
February 2018
January 2018
December 2017
September 2017
August 2017
July 2017
June 2017
May 2017
April 2017
March 2017
February 2017
January 2017
December 2016
July 2016
April 2016
March 2016
February 2016
January 2016
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
August 2013
July 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
September 2012
August 2012
July 2012
June 2012
May 2012
March 2012
February 2012
January 2012
December 2011
November 2011
October 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
May 2008
April 2008
March 2008
February 2008
January 2008
December 2007
November 2007
September 2007
August 2007
June 2007
May 2007
March 2007
December 2006
November 2006
October 2006
August 2006
July 2006
June 2006
May 2006
April 2006
March 2006
February 2006
November 2005
October 2005
September 2005
August 2005
May 2005
April 2005
March 2005
November 2004
October 2004
August 2004
July 2004
May 2004
April 2004
March 2004
February 2004
January 2004
December 2003
October 2003
August 2003
July 2003
June 2003
May 2003
April 2003
March 2003
February 2003
January 2003
December 2002
October 2002
September 2002
August 2002
July 2002
June 2002
March 2002
December 2001
October 2001
September 2001
August 2001
July 2001
June 2001
May 2001
April 2001
March 2001
February 2001
January 2001
December 2000
November 2000
October 2000
September 2000
August 2000
July 2000
May 2000
April 2000
March 2000
February 2000
January 2000
December 1999
November 1999
October 1999
September 1999
August 1999
May 1999
April 1999
March 1999
February 1999
January 1999
December 1998
November 1998
October 1998
September 1998
August 1998
July 1998
June 1998
May 1998
April 1998
March 1998
February 1998
January 1998
December 1997
November 1997
October 1997
September 1997
August 1997
July 1997
June 1997
May 1997
April 1997
March 1997
February 1997
January 1997
December 1996

ATOM RSS1 RSS2



LISTSERV.UNI-HEIDELBERG.DE

Universität Heidelberg | Impressum | Datenschutzerklärung

CataList Email List Search Powered by the LISTSERV Email List Manager