Am 12.10.2011 08:06, schrieb Joseph Wright:
>>> Rather than \regex_extract_once:nnN, I would probably call it
>> Not sure about that. We already have \tl_replace_(once|all):Nnn, which
>> is what prompted me to use once there. @Joseph (and others), would
>> \tl_replace_first:Nnn make more sense than _once?
> For the moment, go with 'once', and we can discuss separately whether it
> should be once/all or first/all in general. (We've only just changed
> this from having 'in' in the name, which has caused confusion enough!)
on first glance "first" feels more precise than once. But I guess this
is not really true since it requires knowledge that processing is left
to right. But personally I like "first" better.
Having said that I agree with Joseph that for now use "once" to keep
common name structures.