There is a name clash between l3io and l3messages. l3io  defines
a \iow_newline: (with colon), whereas l3messages requires a
\iow_newline (without colon).

I am not sure if it should be a function or a variable.

* If it is meant to be a variable as documented, \g_iow_newline
  would be a better name.

* Since \err_newline: is a function, \iow_newline: should be
  a function, too.