On 07/01/2011 06:32, Will Robertson wrote:
> I prefer "void" or "clear" instead of "unset" (all work as noun and verb), but I agree with changing the names. I don't mind the existence of "\box_use_clear:N" (or whatever) but I can see your argument against it. Is there any non-neglible performance decrease from writing
>      \box_use:N \l_tmpa_box
>      \box_clear:N \l_tmpa_box
> over
>      \box_use_clear:N \l_tmpa_box
> ? If not, I'd be happy to drop the use_clear function for the reason of consistency, as you note.

Over all, I think 'void' is possible still the best choice. It suggests 
more than just 'empty', which 'clear' does not. So \box_void:N, 
\box_if_void:N(TF), etc., seem best.
Joseph Wright