schrieb Joseph Wright:
> On 14/06/2011 22:48, Stephan Hennig wrote:
>> 
>>> * The function must have at least one mandatory argument, and in 
>>> particular the last argument must be one of the mandatory types (l, m
>>> or u).
>> 
>> Do I miss something?
> 
> This is a documentation error, which I'll sort out for the next CTAN
> snapshot.

For the time being, using

  \DeclareExpandableDocumentCommand{\foob}{}{FooB}

solves my issues, except for

  * this warning from xparse documentation

        "This facility should only be used when absolutely
        necessary; if you do not understand when this might
        be, do not use these functions!"

    because it applies to me,

  * \DeclareExpandableDocumentCommand doesn't provides all the
    air bags \NewDocumentCommand, \RenewDocumentCommand etc.
    have.

Best regards,
Stephan Hennig