(Sent from my phone.) 

On 30/04/2013, at 11:36 PM, Joseph Wright <[log in to unmask]> wrote:

> This
> test would then be a code level equivalent of \IfNoValue(TF).
> This seems to make some sense to me

I like this too if just as syntactic sugar. Perhaps the test would be sensibly named \xparse_if_no_value:nTF to avoid mixing up the module names?