On 15 Sep 2014, at 4:52 pm, Joseph Wright <[log in to unmask]> wrote:

> I don't remember any technical reasons for not doing this: I guess
> primarily we've not needed it often enough.

I think this was discussed back when I first came on board years ago, and naming complexity / interface simplicity relegated it to the chopping room floor. This was probably before we even had selection of conditions in the {p,TF,T,F} style argument.

> Probably this would go into \prg_... as it's only applicable to
> conditionals (we have \prg_new_eq_conditional:NNn and
> \prg_set_eq_conditional:NNn). I guess something like
> \prg_generate_conditional_variant:Nnn would be an appropriate name.

I think another complaint I had at the time was that ď\prg_generate_conditional_variant:NnnĒ is a pretty big mouthful of a command, but thatís minor :) I donít think we could come up with a shorter and better name but any ideas?