Print

Print



On 21/09/2014 5:40 p.m., Will Robertson wrote:
[log in to unmask]" type="cite">
On 15 Sep 2014, at 4:52 pm, Joseph Wright <[log in to unmask]> wrote:

I don't remember any technical reasons for not doing this: I guess
primarily we've not needed it often enough.
I think this was discussed back when I first came on board years ago, and naming complexity / interface simplicity relegated it to the chopping room floor. This was probably before we even had selection of conditions in the {p,TF,T,F} style argument.


Probably this would go into \prg_... as it's only applicable to
conditionals (we have \prg_new_eq_conditional:NNn and
\prg_set_eq_conditional:NNn). I guess something like
\prg_generate_conditional_variant:Nnn would be an appropriate name.
I think another complaint I had at the time was that “\prg_generate_conditional_variant:Nnn” is a pretty big mouthful of a command, but that’s minor :) I don’t think we could come up with a shorter and better name but any ideas?

Cheers,
Will
A not-too-zealous look through the index to Interface3.pdf gives, in descending order, of length

39 characters
\peek_charcode_remove_ignore_spaces:NTF 

38 characters
\peek_catcode_remove_ignore_spaces:NTF
\__fp_basics_pack_weird_high:NNNNNNNNw

37 characters
\prg_generate_conditional_variant:Nnn
\__msg_kernel_expandable_error:nnnnnn
\use_i_delimit_by_q_recursion_stop:nw


so \prg_generate_conditional_variant:Nnn, although uncomfortably long, would not be a record holder.

Andrew