Print

Print


Hi!
I've experienced the following problem with the
latex/amslatex distribution:

If I use a different ulasy.fd file (for the sauter fonts), the
amslatex crashes at least with the multline* environment:

The problem happens when the NEW ulasy.fd file is loaded
after the amsmath-package.

But if I load the ulasy.fd at format time or I use the
ulasy.fd from the distribution, everything is ok.

Where is the problem?

Following is the new ulasy.fd, a testfile, and the log from
the run. I use also the latest amslatex dist. from CTAN.

I use a different ulasy.fd file:
%%
%% This *was* file `Ulasy.fd',
%%
\ProvidesFile{ulasy.fd}
             [1996/11/20 v2.2d
              Sauter LaTeX symbol font definitions]
\providecommand{\sauter@family}[5]{%
  \DeclareFontShape{#1}{#2}{#4}{#5}
  { <5> #35 <6> #36 <7> #37 <8> #38 <9> #39 <10> #310 <10.95> #311
  <12> #312 <14.4> #314 <17.28> #317 <20.74> #320 <24.88> #325
  }{}%
}
\DeclareFontFamily{U}{lasy}{}
\sauter@family{U}{lasy}{lasy}{m}{n}
\sauter@family{U}{lasy}{lasyb}{b}{n}
\endinput
%%
%% End of file `Ulasy.fd'.



%
% Testfile
%
\documentclass{article}
\usepackage{latexsym}
\usepackage{amsmath}
\begin{document}
\begin{multline*}
  x
\end{multline*}
\end{document}
% eof

%
% from the log-file:
%
...
! Improper \halign inside $$'s.
\next@ ...ce \totwidth@ -\@mathmargin \fi \halign
                                                  \bgroup \hbox
to\totwidth@...
l.15 \end{multline*}
...


%%%%%%%%%%%%%%%%%%%%%%%%%%


--
ciao
norb

---------------------------------
- Preining Norbert
- [log in to unmask]
- University of Technology Vienna
- Austria
---------------------------------