LATEX-L Archives

Mailing list for the LaTeX3 project


Options: Use Classic View

Use Monospaced Font
Show Text Part by Default
Show All Mail Headers

Topic: [<< First] [< Prev] [Next >] [Last >>]

Print Reply
Andreas Matthias <[log in to unmask]>
Sun, 2 Dec 2007 14:35:33 +0100
text/plain (21 lines)
Recently, the names of some control sequences were changed in svn.
Maybe this is a good time to think about other names as well.

* \int_set:Nn uses \numexpr to scan its second argument. Shouldn't
  it rather be called \int_set:Nx?

  The same would apply to \int_add:Nn, \int_sub:Nn, ...,
  \int_to_arabic:n,  ..., \int_compare:nNnTF, ... about most of the
  control sequence names in l3int. And l3skip.

* \quark_if_no_value gives the impression that this is a test
  `if a quark has no value'. But actually it is a test `if a token
  list is equal to \q_no_value'. Wouldn't \tlist_if_q_no_value be
  a better name?
  Same for: \quark_if_nil --> \tlist_if_q_nil