LATEX-L Archives

Mailing list for the LaTeX3 project


Options: Use Classic View

Use Monospaced Font
Show Text Part by Default
Condense Mail Headers

Topic: [<< First] [< Prev] [Next >] [Last >>]

Print Reply
Sender: Mailing list for the LaTeX3 project <[log in to unmask]>
Date: Fri, 13 Feb 2009 06:59:14 +0000
Reply-To: Mailing list for the LaTeX3 project <[log in to unmask]>
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
In-Reply-To: <[log in to unmask]>
Content-Type: text/plain; charset=ISO-8859-1
From: Joseph Wright <[log in to unmask]>
Parts/Attachments: text/plain (20 lines)
Will Robertson wrote:
 >> Should~be~F:~\token_if_expandable:NTF \the {T} {F} \\
> So here, while \the isn't a macro, it will expand when used correctly in
> an edef (e.g., \edef\foo{\the\baselineskip} ).  I've explicitly caught
> undefined macros to return "F" because it just seemed more logical that
> way.


> 3.  Can we think of a less confusing name for it?
>     Maybe  \token_if_will_expand  ?
>     Unless it's only me that finds "\token_if_expandable" confusing.

But if I try to do a single expansion (rather than an \edef), I'll get
an infinite loop with something like \the.  So I'm not sure
"if_will_expand" is really accurate.