Joseph Wright writes:
> On 07/01/2011 06:32, Will Robertson wrote:
> > I prefer "void" or "clear" instead of "unset" (all work as noun and verb), but I agree with changing the names. I don't mind the existence of "\box_use_clear:N" (or whatever) but I can see your argument against it. Is there any non-neglible performance decrease from writing
> > \box_use:N \l_tmpa_box
> > \box_clear:N \l_tmpa_box
> > over
> > \box_use_clear:N \l_tmpa_box
> > ? If not, I'd be happy to drop the use_clear function for the reason of consistency, as you note.
> Over all, I think 'void' is possible still the best choice. It suggests
> more than just 'empty', which 'clear' does not. So \box_void:N,
> \box_if_void:N(TF), etc., seem best.
it's your language guys, but for me the preferred order would be
unset as it is the opposite of "set"
clear I think is bad as it implies to me empty and it such a register isn't
empty is is no longer "set" so that it can be used
Even though no longer of such importance I still think that "unsetting" or
"voiding" a box register after use if no longer needed is a good ground rule,
so to clearly support that I would keep \box_use_unset:N or \box_use_void:N
available, but as Will mentioned writing it out as two function calls is not
too difficult. So I don't mind much (by the way there is also
\hbox_unpack_... etc which should get the same treatment, whatever it is).